Login Student Help Faculty Help cotl

What browsers are compatible with Blackboard?

Microsoft Windows Operating System

  IE 8 IE 9 Firefox 3.6 Firefox (newer)
Windows® XP (32-bit) Compatible Unsupported Compatible Compatible
Windows® Vista (32-bit) Compatible Certified Compatible Certified
Windows® Vista (64-bit) Compatible Compatible Compatible Compatible
Windows® 7 (32-bit) Compatible Certified Compatible Certified
Windows® 7 (64-bit) Compatible Compatible Compatible Compatible

Certified: fully tested and supported. 
Compatible: partially tested but should function properly.

Apple® Mac OS® Operating System

  Safari® 4.0 Safari® 5.0 Firefox 3.6 Firefox (newer)
Mac OSX 10.5 "Leopard®" Compatible Compatible Compatible Compatible
Mac OSX 10.5 "Snow Leopard®" Compatible Certified Compatible Certified

Note:

  • We are currently in the process of testing "Chrome". We will update the information once completed.

  • Blackboard Learn requires the latest version of Sun JRE 6 (Java). The JRE can be downloaded from http://java.sun.com/javase/downloads/index.jsp.

  • The following technologies are not supported:

    • Internet Explorer 6 and Internet Explorer 7
    • Firefox 1.x, 2.0, 3.0, and 3.5
    • Safari 2.0, 3.x  (or any version on Windows)
    • Mac OSX 10.4 "Tiger"
    • Java 5

Information source: http://kb.blackboard.com/pages/viewpage.action?pageId=84639794

 

 

Black Footer Bar Footer